ISMap Guide

Introduction to ISMap..................................................................................................................... 1
Part 1:  Depth Structure Example.................................................................................................... 2
  Reading the Seismic Data into ISMap ........................................................................................ 8
  Cross Plots ................................................................................................................................ 15
  Variogram Modeling .................................................................................................................. 18
  Kriging the Well Log Data ........................................................................................................ 23
  Cokriging the Well Log and Seismic Data ............................................................................... 26
  Conditional Simulation ............................................................................................................. 32
  Transforming Output Maps ....................................................................................................... 36
  Saving the Project and Exiting the Program ............................................................................ 40
Part 2:  Porosity Example using GeoView and Seismic ............................................................... 41
  Reading the Well Log Data into ISMap from GeoView .......................................................... 44
  Variogram Modeling ................................................................................................................ 51
  Kriging the Well Log Data ........................................................................................................ 53
  Reading the Seismic Data into ISMap ...................................................................................... 56
  Creating Data Slices .................................................................................................................. 65
  Reading Data Slices into ISMap ............................................................................................... 70
  EMERGE Analysis ..................................................................................................................... 80
  Reading EMERGE Slices .......................................................................................................... 91
GUIDE TO ISMap

Introduction to ISMap

ISMap is an interactive program designed to help the geoscientist integrate multiple sets of geological or geophysical measurements, using the techniques of geostatistics. An example of this would be well log and seismic information about a parameter such as event structure or porosity. To this end, ISMap contains a range of geostatistical display and analysis tools, such as cross plotting, histograms, variogram analysis, kriging, cokriging, and conditional simulation. In this guide section, we will apply these techniques to several real data sets that have been supplied.

This tutorial is divided into two parts and each one can be run independently. These parts are:

Part 1:
This demo applies the ISMap program to the problem of depth conversion. Two data sets are read in from ASCII files. The first ASCII file contains a set of measured depths from well logs. The second ASCII file contains horizon times picked from seismic data. The objective is to create a depth map.

Part 2:
This demo creates a porosity map. In this case, the well log porosities are extracted directly from the GeoView database. Also, the seismic window is used to extract multiple attribute slices directly from seismic volumes.

Next, the EMERGE process is used to optimally combine a series of seismic attributes, and use them to predict the porosity map.
To begin this tutorial, first start the GeoView program. If you are using a Unix-based operating system, go to a command window and type in the command:

```
GeoView <RETURN>
```

On a PC, GeoView is initialized by clicking the Start button and selecting the GeoView option on the Programs / HRS applications window.

When you first launch GeoView, the first window that you see is the Opened Database List, which displays your recently used databases. For this part of the tutorial we don’t need a database, so you can click Cancel:

Start the ISMap program by clicking the ISMap button on the GeoView main window.
On the **Project Selection Mode** window, just click **OK** to select the default, which is **Start a New Project**. On the **New Project** window, enter *structure* as the new project name, and then click **OK**.

The **ISMap** main window then appears:
In this project, we will be creating a depth structure map using both picked well depths and seismic structure time values. This will involve reading data into ISMap. We will start with well log data. To read the well log data, select Select Data>New Well Log Data. This brings up the following window:

Notice that you can read the data either from a file or from the database. In most cases, your choice will be determined by what data you have available. In this demo, we will use the ASCII File option.

Choose the ASCII File option and click OK. You will now see the File Selection window. Go to the ISMap data directory and select the file named dpth_str.txt, as shown:

Then click Open or OK and the Well Data ASCII Format window will appear, allowing you to specify the format of the ASCII file.
On this window, you tell the program which columns contain the X and Y coordinates and the data values.

To help you to fill in the window, click the **Display file** button to display the contents of the file:
Notice that the data consists of X and Y locations in columns 1 and 2, and a depth structure value in column 3. Also, there are two lines at the top of the file that do not contain well values. If the well names were included as one of the columns of the file, they could also be read in. However, this is not the case for this file. Fill in the Well Data ASCII Format window as shown below:

When you have completed the window as shown, click OK, and the Edit Well Name and Unit window appears. Fill in the window as shown below and click OK.
The well data is annotated on the screen:

The wells have been posted at their correct location, and their depth values have been color coded, with the legend shown on the right of the window. Notice that the wells are concentrated in the center of the survey area.

If the color scale is not the same as above (green at the top, passing through yellow, red and blue to end at purple), you can change it using either the View>Change Color Amp or View>Change Color Key options. The simplest option is the View>Change Color Amp. Click this option to bring up the following window:

If your numbers are different from those shown, simply type in these values and click OK. Note that the Recalculate Color Amplitudes button will compute the amplitude range from the data itself.
Next, select the **View>Change Color Key** option, to get the following window:

![Change Color Key Menu](image)

Notice that this is a much more advanced color bar editing feature that allows you to change the number of colors and the colors themselves. For now, we will use the defaults.

**Reading the Seismic Data into ISMap**

Before loading the seismic data, let us set the grid size by clicking the **Define Grid** button and filling out the window as follows:

![Define Grid](image)
The next step is to read in structure times picked from a seismic survey. To do this, select **Select Data>New Seismic Data**. This brings up the following window:

You will again note that there are two ways to bring in a seismic dataset, either using the **ASCII File** option or from an existing **Project**. The **ASCII File** option is exactly the same as for well log input, and will be discussed first. Since this is the default, simply click **OK** to get the **Open ASCII Seismic Data File** window. Select the file called `time_str.txt`, as shown below, and click **Open**:

The next window that appears is the **Seismic Data ASCII Format** window.
Click the **Display file** button to see the contents of this file:

![File Display](image)

<table>
<thead>
<tr>
<th>Input</th>
<th>Time Structure Map</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>40</td>
<td>0</td>
</tr>
<tr>
<td>80</td>
<td>0</td>
</tr>
<tr>
<td>120</td>
<td>0</td>
</tr>
<tr>
<td>160</td>
<td>0</td>
</tr>
<tr>
<td>200</td>
<td>0</td>
</tr>
<tr>
<td>240</td>
<td>0</td>
</tr>
<tr>
<td>280</td>
<td>0</td>
</tr>
<tr>
<td>320</td>
<td>0</td>
</tr>
<tr>
<td>360</td>
<td>0</td>
</tr>
<tr>
<td>400</td>
<td>0</td>
</tr>
<tr>
<td>440</td>
<td>0</td>
</tr>
<tr>
<td>480</td>
<td>0</td>
</tr>
<tr>
<td>520</td>
<td>0</td>
</tr>
<tr>
<td>560</td>
<td>0</td>
</tr>
<tr>
<td>600</td>
<td>0</td>
</tr>
<tr>
<td>640</td>
<td>0</td>
</tr>
<tr>
<td>680</td>
<td>0</td>
</tr>
<tr>
<td>720</td>
<td>0</td>
</tr>
<tr>
<td>760</td>
<td>0</td>
</tr>
<tr>
<td>800</td>
<td>0</td>
</tr>
<tr>
<td>840</td>
<td>0</td>
</tr>
<tr>
<td>880</td>
<td>0</td>
</tr>
<tr>
<td>920</td>
<td>0</td>
</tr>
<tr>
<td>960</td>
<td>0</td>
</tr>
<tr>
<td>1000</td>
<td>0</td>
</tr>
<tr>
<td>1040</td>
<td>0</td>
</tr>
</tbody>
</table>

From the file listing, we can see that the Crossline (X) coordinates are in column 1, the Inline (Y) coordinates are in column 2, and the time structure values are in column 3. The first part of the file contains null values that are written as the number -1.00000E+21, but if you scroll down you will see live values. Also, the header consists of 2 lines that give valuable information to us but need to be skipped by the program.
Fill in the **Seismic Data ASCII Format** window as shown below:

![Seismic Data ASCII Format Menu](image)

Next, press the **OK** button and the **Edit Seismic Name and Unit** window appears:

![Edit Seismic Name and Unit](image)

Fill it in as shown, and click **OK**.
The following display of the seismic structure map appears:

Again, if your color scale is not the same as above, you can change it using either the View>Change Color Amp or View>Change Color Key options. Click the View>Change Color Amp option to bring up the following window:

If your numbers are different from those shown, simply type in the values shown above and click OK. If they are the same, click OK or Cancel.
Next, select the **View>Change Color Key** option, to get the following window:

![Change Color Key Menu]

Again, we will use the defaults.

There are a number of options for modifying the plot parameters of this window. You can access all of these options by clicking the **View** button. The first thing we want to do is change the map from unscrolled to scrolled mode, so that the aspect ratio is correct. Click **View>Display Options** and fill in the window as shown below:

![Display Menu]

Note that we have changed both the X and Y-axis ranges to **Scrolled** mode and have set the scale to *1250 units/inch* for both axes. Click **OK** to get the following display:

One important option is to look at a histogram of the input data. To do this, select **View> Histogram**, to get this plot:

Note that the histogram may be calculated for any of the subsequent maps that we will produce. Also, you may change the histogram parameters by selecting the **View** option on this plot.
Cross Plots

The first thing that we always want to do when comparing two datasets is to crossplot them against each other. To do this, click the Display button on the vertical sidebar menu and select Cross Plot from the pull-down menu. This will bring up a display of the crossplotted values as shown below:

This display contains one point for each location on the grid that has both a well data value and a seismic data value. Of the 25 wells, only 23 are displayed. This is because we have set the search distance for the crossplot to 80 units. To see the outlying points, select Edit>Cross Plot Parameters. Fill in the window as shown below:

Click OK, and a new Cross Plot appears with all 25 well points.
If you wish to see the map location of any crossplotted point, position the mouse crosshair near the point or points of interest, press the left mouse button, and drag across the points. A box will then enclose the points.

Look at the map display of the data and you will see that the corresponding point on the map is blinking.

Delete the point shown above from the crossplot by using your mouse to outline a window around the point, as shown, and then selecting **Edit>Delete**. The point will turn gray and the new correlation coefficient will be calculated.

We have highlighted a point on the crossplot to see where it falls on the map view. We have also deleted a point from the crossplot. Another option is to delete points from the map view.

The **ISMap** main window, which is our map view, will now show the outlier point in gray. Notice that this point is outside of the map area, which explains why it did not fit on the crossplot. There is another well at \((x, y)=(3600, 2100)\) which is also out of bounds. Use the mouse to drag a box around this point and then select **Edit>Delete** to remove this point. You will see that this deletion improves the correlation coefficient on the cross plot only very slightly.
Next, let’s apply the regression fit from the crossplot to the seismic data. Click the **Display** button on the vertical menu, and choose **Apply Regression** from the pull-down menu. This will produce the following display:

![Linear Regression Applied To Input Data](image)

Notice that both the wells and seismic data are now colored with a depth scale. However, the wells do not match perfectly, since there was scatter in the crossplot.
**Variogram Modeling**

The variogram is the mathematical function that measures the spatial continuity in our two data sets. It contains information about how well correlated the data points are and whether there are directional continuity patterns.

First we will calculate the variogram for the well data. Click the **Variograms** button and select **Well to Well**. This will bring up the **Variogram Analysis** window. Fill in the window as shown below:

By using the parameters shown above, we are calculating an isotropic variogram with 10 offsets ranging from 0 to 1500 meters. When you have filled in the window as shown, click **OK** and the following variogram will appear:
On this display, the black points represent the calculated values and the red line shows the modeled variogram. To look at the model parameters and modify them, click the **Options** button at the top of this window and select **Set Parameters** from the pull-down menu.

The default variogram model is a **Spherical** model with a single structure. The parameters have been set automatically by the program in such a way as to fit the measured points. This window allows you to modify these parameters and see the effect. In this case, we will not modify anything since the variogram looks good. Click **Cancel** to exit the window.

While still in the **Variogram Plot**, there are several other options that we should look at. For example, to see the number of values used to calculate each black dot, select **View>**Show **Count**. Notice that a histogram appears on the variogram plot, with its scale posted on the right hand side, as shown here:
Another way of looking at the same information is to compute the covariance function. To display this function, select View>Show Covariance. The resulting plot looks like this:

Unlike the variogram, which is the sum of the squared differences of the values at different offsets, the covariance is the sum of the products of the values. Thus, the covariance is large where the variogram is small, and vice versa. After looking at the covariance, click View and set the display back to Show Variogram. Then, select File>Exit on the variogram plot to remove the display.

Next let us look at the seismic variogram. To do this, select Variograms>Seismic to Seismic. On the Variogram Analysis window, change the Maximum offset to 3500 and the Number of offsets to 20, as shown below:
Next, click **OK** to get the following display:

Notice the excellent fit of the modeled variogram to the calculated points. Notice also that the range is much longer than the Well-to-Well variogram.

With such a large number of data points, we should test for possible anisotropy, that is, a change in the variogram with direction. To do this, select **Options**>**Analyze data** at the top of the window. On the resulting window, change the **Number of directions** from **One** to **Two**, make sure the maximum offset is still set at 3500, and click **OK** to recalculate a new variogram. The result will look like this:

Notice that two variograms have been computed. The lower points represent the 0 degree (north-south) direction, and the upper points represent the 90-degree (east-west) direction. The curve represents the average modeled variogram. The interpretation of these results is that the range of the data is greater in the north-south direction than in the east-west direction, indicating anisotropy.
Another way to investigate anisotropy is to look at the **Covariance Map**. Covariance is calculated whenever you use more than one direction in the variogram analysis. To see this plot, select **View>Show Covariance Map** on the **Variogram Plot**:

The covariance map shows the calculated variances as a function of direction as well as distance. Notice the bias in the northwest-southeast direction. (An isotropic map would have a circular covariance display). The black circle shows the (isotropic) modeled range. To modify the model to reflect the anisotropic properties of this data set, we would select the **Options>Set Parameters** items on the **Variogram Display**. For now, we will continue this guide example using the isotropic variogram model.

We will compute one more variogram before finishing this section, the Well-to-Seismic variogram. From the main window, select **Variograms>Well to Seismic**. Fill in the **Calculate Variogram From Data** window as shown below:
Click OK. The following variogram will then appear:

![Variogram Plot]

The Well-to-Seismic Variogram contains the implicit relationship between the sparse (well) data and the dense (seismic) data. This relationship is also contained within the regression fit on the Cross Plot Display. As we will see in the following sections, either of these measures may be used during the kriging or simulation of the well log data.

**Kriging the Well Log Data**

We now want to make our first geostatistical map, a kriged display in which we optimally contour the well log data. To do this, click the Kriging button on the ISMap main window to bring up the following window:

![Kriging Window]
For this map, simply use the defaults. That is, we will do ordinary kriging with a maximum number of samples that includes up to 20 neighboring wells and a maximum radius over the complete map surface. Click OK to compute the kriged map. This will produce the following display:

![Kriging Result](image)

Another diagnostic map that is useful when analyzing geostatistical results is the error map. To produce this plot, click the **Display** button on the ISMap main window and select **Latest Error>Kriging**. This will produce the map shown below:

![Kriging Error](image)

Notice that, as expected, the error is smallest around the wells and gets larger towards the edges of the map.
Finally, one more diagnostic plot can be produced, called the **Cross Validation Display**. Cross Validation is the process of deleting one well at a time from the kriging calculation, predicting its value from the other wells, and displaying the error associated with that prediction. To produce this display, click the **Kriging** button on the **ISMap** main window and fill in the **Kriging** window as shown below:

Click **OK** to produce the final map. This map shows the absolute error. To see the percent error, select **View>Percent Error**. The final plot looks like this:

In this section, we have produced a series of maps using the well log data alone. In the next section, the seismic data will be used to enhance the interpolation process.
Cokriging the Well Log and Seismic Data

Now that we have seen the results of kriging the well log data, we will move to the next stage in our geostatistics analysis, that of cokriging the well log data using the seismic data as a secondary variable. This will produce a map that honors the well data, but uses both the seismic data and the variograms to interpolate between the wells.

To perform cokriging, click the **Kriging** button and select **Conventional Cokriging**. This is the traditional approach to cokriging and will use all three of the variograms that we have calculated. Also, a range of seismic data around each grid point is used in the calculation (this is different from **Collocated Cokriging**, which we will discuss next).

Fill in the window as shown below (note that we do not select **Assume Linear Relationship**):

Click **OK** and you will see a dialog warning you that the variograms are not positive definite.
This warning can be ignored, so press **Yes**, and the following map will be produced:

![Map Example](image)

This map looks very similar to the kriged result except that details from the seismic are more evident.

An alternative to **Conventional Cokriging** is to use the technique of **Collocated Cokriging**. This approach differs from **Conventional Cokriging** in that as each grid point is calculated, and only the single seismic data value closest to that point is used, so the speed of the process will be much faster than for conventional cokriging. Also, we may use the linear relationship between the well and seismic data to simplify our analysis by requiring only one variogram.

To start the process, click the **Kriging** button and then choose **Collocated Cokriging** for the **Type of Kriging**. Notice that the **Assume Linear Relationship** button is automatically checked when this option is chosen. The completed window should look like this:
Then, click **OK** to get the **Markov-Bayes Parameters** window. We will use the default on this window and calculate the $a$ and $b$ coefficients from the crossplot. Also, we will use the seismic-to-seismic variogram, since this is the most reliable.

The completed window looks like this:

Then, click **OK** to produce the following map:
Notice that this map does a better job of honoring the seismic data than the previous cokriged result. In fact, the fit is excellent. To look at the cokriging error, click the **Display** button and choose **Latest Error>Co-kriging** from the pull-down menu. The error looks like this:

As a final example of cokriging, we will explicitly incorporate the trend from the seismic data. On the **ISMap** main window, select **Transform>Remove Trend**. Fill in the window as shown here:

As shown above, we are using a square smoother with dimensions of 1000 by 1000.
Click **OK** to see this new window showing the trend derived from the seismic:

![Image of trend from seismic data]

There will be another window that shows the trend from the well data. Also, the input seismic data will show the residual after subtracting the trend from the seismic data:

![Image of input data trend removed]

We will now redo the variogram calculation by selecting **Variograms>Seismic to Seismic** to bring up the existing variogram, and then selecting the **Options>Analyze data** button on the variogram plot to bring up the parameter window.
Fill in the window as shown here:

![Calculate Variogram From Data Window]

Then, click OK to get the following display:

![Variogram Plot]

Notice that the variogram has a smaller range than before because we are using the residual data. Now redo the cokriging with the same parameters as before (Collocated cokriging with the Markov-Bayes assumption) to get the following result:

![Cokriging Result]

January, 2007
Conditional Simulation

Simulation is the process of creating a set of maps, all of which honor the sparse (well) data exactly, and at the same time display the spatial continuity properties implicit in the variogram. These maps are said to be “equi-probable” in the sense that they are all consistent with the known information. However, they are not strictly random, because they are constrained by the variogram model, as well as (optionally) the secondary dense data.

The simulation maps differ from the kriged or cokriged maps in that they contain the possibility of large deviations or outliers. If you think of each grid point on the final map as a probability distribution, kriging always gives you the peak of that distribution, while simulation maps may give other points on the distribution with a probability determined by the distribution shape. Generally speaking, kriged maps are smoother - the bias in the kriging algorithm is towards as little variation as possible, consistent with the hard data. Simulation maps may show the extreme possibilities that are still consistent with the hard data.

While simulation maps are interesting in themselves as displays of possible outcomes, they are most useful when analyzed to see distributions of features. For this purpose, we must first create a series of maps, and then analyze those maps to display various properties.

To start the process, select Simulation>Create Maps. Fill in the following window as shown:
As you can see from the window, we are going to create 10 maps, using both the well log and seismic data. We have also checked the **Assume Linear Relationship** option, which means that only one variogram will be used. When you have completed the window as shown, click **OK** to bring up the next window. The **Markov-Bayes Parameters** window appears because of the assumed linear relationship. The parameters are the same as we used previously during Collocated Cokriging. Now, click **OK** to create the maps. This will create ten different versions of the cokriged map using Sequential Gaussian Simulation (SGS). The final simulation looks like this:

To display another result, select **View>Select Result**. Choose result 5 and click **OK**:

Looking at the ten displays will show you the range of possible structures that honor the wells. However, it is difficult to assimilate all of this information simply by looking at the maps. Therefore, **ISMap** has a feature that enables you to analyze the results of the simulation in a more revealing way. To perform this analysis, select **Simulation>Analyze Results**. This brings up the **Simulation Analysis** window. There are three types of analysis that can be done: an average of all the maps, a probability map that a certain range of values is present, and a distribution map of those values that are above a certain probability (called an indicator map).
Fill in the window as shown here:

We have set the **Type of Analysis** to **Probability** and entered **1690** for the **Low Value**, and **1700** for the **High Value**. Click **OK** to get the following map:

This map shows the probability of finding a structure with depths between 1690 and 1700 meters.
Select the **Simulation>Analyze Results** option again. Fill in the **Simulation Analysis** window as shown below:

![Simulation Analysis Window](image)

Click **OK** to get the following result:

![Result Map](image)

This map shows those locations where the probability exceeds 50% that the depth is between 1690 and 1700 meters. Try this option with values higher and lower than 50% and you will see the area shrink or expand. If the color scale is not the same as above, simply select **View>Change Color Key** and change the value to 0.5.
Transforming Output Maps

We have created several maps using kriging and cokriging. We wish to see the list of maps created so far. Select Display from the vertical menu on the ISMap main window. The List of Results item represents all the kriging and cokriging operations done in the project. Click List of Results. A Saved Results List appears:

![Saved Results List](image)

We wish to compare the last two cokriging results. Select ID 4 from the Saved Results List menu and press the Show button. This should bring up the cokriged result that was calculated after explicitly removing the trend:

![Cokriging Result](image)

Select View>History Text. A notepad appears with all the data and parameters used in generating the map.
The last item should be information associated with the trend smoother length.

From the **Saved Results List** menu select ID 3. Click **Show** to bring up the other cokriged map, which was calculated without removing the trend:
Select **View>History Text** to look at the parameter history.

We can modify the **Results List** to give more description to our maps. Fill in the window as shown below, and click the **Close** button.
Next we wish to make a map showing the difference between the two cokriged results.

Click the **Edit** option from the horizontal menu of the **Saved Cokriging Result: 4**. From the pull-down menu, select **ISMap Map Utilities>Dual Maps**. The following window appears. Fill it in as shown below:

Click **OK** to see the difference between the two results.
Saving the Project and Exiting the Program

This completes our look at the ISMap program using a structure map from the wells and an isochron map from the seismic data. To exit from ISMap, select File>Exit Project on the ISMap main window. Before closing down, ISMap will prompt you to save the current project:

![ISMap exit confirmation dialog]

A “project” is the set of all the current parameters and results. By saving the project with a particular name, you can later restore that project and retrieve the current results. Also, the project mechanism provides “crash protection”. This means that if the ISMap program crashes because of either software or hardware problems, you may restart the program and open the current project. All the results will be intact, as they were when the system went down. Click Yes on this window to indicate that you want to save this project.
**Part 2: Porosity Example using GeoView and Seismic**

If GeoView is not already running, refer to the instructions at the beginning of this tutorial to start the program.

The GeoView main window will look like this:

![GeoView Main Window](image)

For this part of the tutorial, we will access a well log database called ISMap_database which has already been created for you. Select the **Database>Open** option on the horizontal menu. The following window will appear:

![Database Open Window](image)

A GeoView database consists of a series of directories. The upper level directory has the extension *wdb*, e.g.: *ISMap_database.wdb*. Click the folder named *ISMap_database.wdb*, and then click **OK**.
This will open the *ISMap_database* database, which contains 12 wells from the Blackfoot area of Western Canada. These wells are listed in the GeoView Well Explorer window:

Select the well named 01-17 and click Display Well to bring up a plot of the curves digitized for this well. The window will look like this:
The GeoView Well Explorer window allows you to see information about any of the wells in the database:

You can edit any of this information if something needs to be changed.

To see more information on the logs in a particular well, 01-17 for example, click the arrow button to the left of its name. This changes the Table View as shown:

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>01-17</td>
<td>65.00</td>
<td>40.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>04-15</td>
<td>63.00</td>
<td>26.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>05-15</td>
<td>60.00</td>
<td>26.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>08-08</td>
<td>28.00</td>
<td>41.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>09-08</td>
<td>38.00</td>
<td>41.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>09-17</td>
<td>95.00</td>
<td>46.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>11-08</td>
<td>38.00</td>
<td>59.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>12-15</td>
<td>95.00</td>
<td>27.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>13-15</td>
<td>113.00</td>
<td>17.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>14-09</td>
<td>55.00</td>
<td>17.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>16-03</td>
<td>51.00</td>
<td>39.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
<tr>
<td>20-03</td>
<td>47.00</td>
<td>39.00</td>
<td>m</td>
<td>ABANDONED GAS WELL</td>
<td>0.00</td>
<td>0.00</td>
<td>m</td>
</tr>
</tbody>
</table>

There are 12 wells in this table.
To see a list of the tops entered for this well, click the arrow button beside **Tops** to modify the **Table View** again:

<table>
<thead>
<tr>
<th>Top Name</th>
<th>Start Measured Depth</th>
<th>End Measured Depth</th>
</tr>
</thead>
<tbody>
<tr>
<td>TOP</td>
<td>1557.00</td>
<td>1557.00</td>
</tr>
<tr>
<td>BASE</td>
<td>1562.00</td>
<td>1562.00</td>
</tr>
</tbody>
</table>

Select **File>Close Window** to remove the **GeoView Well Explorer** window.

**Reading the Well Log Data into ISMap from GeoView**

To launch **ISMap**, click the **ISMap** button on the **GeoView** main window. When the **Project Selection Mode** window appears, choose the option to **Start a New Project**.
Name this project **porosity**, as shown below, and click **OK**:

![Image of New Project window]

To load the well log data into this project, select **Select Data>New Well Log Data**. This brings up the following window:

![Image of Read Log Data window]

Notice that you can read the data either from a file or from the database. In most cases, your choice will be determined by what data you have available. In this case, we will read data from the well log database. Select the **Database** item as shown and click **OK**.
The **Well Log Selection** window allows you to select all the wells in the database or any subset of them. In this case, select them all by clicking the **Add all>>** button.

Now, click **OK** to bring up the **Well Log** window.
This window allows you to choose from any of the curves or tops that have been included in the database. You can average these curves over zones around the tops or between tops. In this case, let us select *Porosity* by averaging from the top *TOP* to the top *BASE*. Fill in the window as shown above, and click **OK**.

The next window that appears is the **Edit Well Name and Unit** window:

![Edit Well Name and Unit](image)

Enter % under **Unit**, and click **OK**.

Two things will happen. The first is that the **ISMap** main window will now show the porosity posted on the grid. The second is that a new display will appear, which shows a portion of the selected wells:

![Log Display](image)
In this display, the zone that has been averaged is highlighted in red. Also, the logs are “flattened” on the chosen horizon, TOP. To see the logs at their original depth location, click on the View parameter at the top of the window:

Notice that one of the options is Flatten on Top, and this has been selected. Click that item to toggle it off and the new display is produced:
On the Log Display window, select **File>Exit** to remove the display. Notice that the well values have been displayed on the main window, as shown here:

Note: If the X and Y axes are scaled incorrectly so that the wells are all squeezed into one corner of the grid, the program may have “remembered” some previous settings. Simply select **View>Display Options** and either change to **Unscrolled** mode or change the **Units/Inch**.

Also, if the color bar is different from the one shown above, you may either leave it alone or change it to the above color bar by selecting **View>Change Color Amp** and making the changes shown in the next window.
Click **OK** to save the changes. A more complete color editing scheme is found in the **View>Change Color Key** window, as shown below:

![Change Color Key Menu](image)

Right now, we will use the default settings in the preceding window.

Now, we wish to create a kriged map with this data. This involves first computing a variogram model, and then kriging the data.
Variogram Modeling

The variogram is the mathematical function that measures the spatial continuity in our dataset. It contains information about how well correlated the data points are and whether there are directional continuity patterns.

We must first calculate the variogram for the well data. Click the Variograms button and select Well to Well. This will bring up the Variogram Analysis window. Fill in the window as shown below:

By using the parameters shown above, we are choosing to calculate an isotropic variogram with 6 offsets ranging from 0 to 42 units. Click OK and the variogram will appear. Select View>Show Count to see the number of pairs of wells in each calculated point. The final display will look like this:
On this display, the black points represent the calculated values (with the number of pairs that went into the calculation shown by the bar with a scale on the right side) and the red line shows the modeled variogram. To look at the model parameters and modify them, click the **Options** button at the top of this window and select **Set Parameters** from the pull-down menu.

This will display the following window:

![Variogram Parameters Window](image)

The default variogram model is a **Spherical** model with a single structure. The parameters have been set automatically by the program in such a way as to fit the measured points. This window allows you to modify these parameters and see the effect. In this case, we will not modify anything since the variogram looks good. Click **Cancel** to exit the window.
Kriging the Well Log Data

We now want to make our first geostatistical map, a kriged display in which we optimally contour the well log data. To do this, click the Kriging button on the main ISMap window to bring up the following window:

For our first map, simply use the defaults. That is, we will do ordinary kriging with a maximum number of samples that includes up to 12 neighboring wells and a maximum radius that “sees” the complete map surface. Thus, click OK to compute the kriged map.
There are several interesting diagnostics that can be displayed to see how well the kriging has worked. First, click the Display button and select Latest Error>Kriging. This will produce the following plot of the error in the kriged map:
As expected, the error is smallest around the wells. Finally, click the **Kriging** button again, and check the **Cross Validation** button at the bottom of the **Kriging** window. Click **OK** to produce the cross-validation plot.

![Cross Validation Result](image)

The cross-validation plot shows the effect of removing the wells one by one in the kriging process, and then comparing the known value of the removed well to the new kriged map. Next, Select **View>Cross Plot** at the top of the display to get the following display:

![Cross Validation Cross Plot](image)

This plot shows the true well value versus the estimated value for each of the wells.
Reading the Seismic Data into ISMap

In this section, we will load two seismic volumes. The seismic module is used to display SEGY files and create data slices for analysis in ISMap. To open the seismic volume, select Seismic>Open Seismic>From SEGY File:

The first file is called seismic_ISMap.sgy. Select it as shown below and click Next >> on the window:

The next window that appears allows you to specify whether the data is 3D or Straight Line, as shown below:
Since our data is 3D, click Next >> to get the following window. This page is used to tell the program which values will be read out of the trace headers. In our case, we have Inline & Xline numbers in the header, but we do not have X & Y coordinates. Select the answer “No” to the question: Do you have X,Y coordinates in the trace header?

Then click Next >> to get the next page:

The format page is a very detailed page where you specify where various items are contained in the headers. The default values correspond to standard SEGY locations. The important locations for our case are the Inline and Xline Byte locations. The defaults are correct. Click Next >> to get the next page. Now you will see the following warning:
This window is warning you that the program will now scan the entire file, collecting information from the headers. Click **Yes** to start the scan. When the scan has completed, the **Geometry** page appears:

Click **OK** on this window, to accept the default geometry. Two new windows now appear. One is the seismic window, displaying Inline 1 of the seismic volume:
The second window shows the mapping between the well locations in **GeoView** and the trace positions on the 3D volume:

Click **OK** on this window to accept the calculated well locations. To see where the well locations are located within the seismic volume, go to the seismic window and select **View>Base Map**. This will bring up the following display, which shows all the well locations and a base map of the seismic survey:

Now, move your cursor to the map and position it over the center of well 14-09. Notice that the display on the bottom line of the map tells you that this well is at Inline 56 and Xline 18.
To see the inserted sonic log, double-click on the well location. The seismic window will be updated to display Inline 56:

Now, change the display mode from **Inline** to **Xline**, and type in the number **18** and press **Return**. This will show the following display:

Notice that there are two wells on Xline 18, **14-09** and **13-16**. Also note that the wells have been correlated prior to being loaded into the project. If the wells had not been correlated, you could use **eLog** to perform the correlation. However, for **ISMap** we will use the tops to extract well information, and therefore correlation is only necessary for visual agreement.
Now we will read a second SEGY volume. Once again select **Seismic>Open Seismic>From SEGY File**:

This time, select the file *inversion_ISMap.sgy*:

This is an inversion result that has been created in **STRATA**. Click **Next >>** on this window and on the next window (to select 3D data).

On the **General Information** window, once again click **No** in answer to the question about X & Y coordinates in the trace header, as shown below:
Accept the default on all the subsequent menus. When the inversion data appears, it will look like this:

To see a color display of this data select View>Color Traces: Shown:

The final data we will read into the project is a horizon that has been picked previously.
On either of the seismic windows, select **Horizon > Import Horizons > From File**: 

Select the file *ch_top.hor* and click **OK**:

On the window, select the **File Type** to be **Free Format**:

**Specify Pick File Format**

- **File Type**: 
  - Default Landmark
  - Default Georeferenced
  - Free Format
  - Fixed Format

- **Insert Pick by Matching**: 
  - CDP Number
  - Inline and Xline Number
  - X and Y Coordinate

Multiple Horizons in file:  
- **Yes**
- **No**

Notes on Matching Pick:

Selected files must have same file type.

Display the first selected file
On this page, just change the **Number of lines to skip** to 1 as shown above. Click **OK** on this window to read the horizon. Note that the horizon will appear in both seismic windows. On the Inversion window, display Xline 18 and scroll to the right end of the line to see the following display:

![Image of seismic data with horizons](image-url)

Note that the *ch_top* pick lines up with the channel sand on both wells.
Creating Data Slices

We now have 2 SEG-Y volumes. We now want to create data slices from each of the volumes, which will then be used in the ISMap project.

Go to the seismic window containing the seismic data (*not* the inversion data) and select Process\>Slicing\>Create Data Slice:

Change the first page of the window to look like this:

![Plotting Attribute Specification](image)

Notice that we have changed the default, which was to use only the *Amplitude* from the seismic_ISMap volume, to include *Amplitude Envelope, Instantaneous Phase, Instantaneous Frequency, Integrated Trace, and Trace Length* attributes.
Click **Next >>** to get the next page and set the parameters as shown below:

### Data Slice Parameters

**Select a Data Slice**
- At a Constant Time
- Near a Picked Event
- Event Plus Constant Time

**Constant Time (ms):** 1050

**Picked Event:** ch_top

**Event + Time (ms):** 0

**Second Event:** ch_top

**Method for Choosing Picks**
- Use Actual Picks
- Use Interpolated Picks

**Method for Choosing Data Window**
- Use Exact Time
- Average Window Above
- Average Window Centered
- Average Window Below
- Average to the Second Event

**Window Size (ms):** 10

**Alpha Trim Rejection (%):** 10

This will extract the RMS average amplitude over a 10 ms window below the *ch_top* horizon. Click **Next >>** to get the last page of the window, and then use the default to keep the name of the slices the same as the input dataset. Then, click **OK** to create the data slices. Notice that all six slices are stacked up as shown below:

You may want to look at each of the slices individually.
Next, select **Process>Slicing>Data Slice Archives** to see the following display:

![Data Slice Archives](image)

The **Data Slice Archives** tells you that you have created six slices, all with the prefix `seismic_ISMap`, and with suffixes indicating the type of slice, for example `freq_rms_average`. This window can be used to redisplay the slices if the windows currently on the screen are closed down.

Now go to the window containing the inversion data, and go to **Process>Slicing>Create Data Slice** again:
Use the default (**Amplitude**) from the first window, as shown below:

![Plotting Attribute Specification](image)

Click **Next >>**, and on the next window, set the extraction window to be 10ms below the horizon *ch_top*:

- **Select a Data Slice**
  - At a Constant Time
  - Near a Picked Event
  - Event Plus Constant Time

- **Method for Choosing Data Window**
  - Use Exact Time
  - Average Window Above
  - Average Window Centered
  - Average Window Below
  - Average to the Second Event

- **Constant Time (ms):** 1050
- **Picked Event:** *ch_top*
- **Event + Time (ms):** 0
- **Second Event:** *ch_top*

- **Window Size (ms):** 10

- **Arithmetic Mean**
- **RMS Average**
- **Minimum**

Then, click **Next >>** to get the next window and default the name of the slice to *inversion_ISMap*. 
Click **OK** to see the following plot:

![Plot](image)

This slice will also be added to the data slice archive.

Note that this method of creating slices will only allow you to create the basic nine attributes shown on the **Data Slice** window (this includes isochron, time structure, and cosine of instantaneous phase in addition to our six choices.) If you want other attributes, you can create new attribute volumes themselves. As an example, go to the window containing the seismic data and select **Process>Seismic Attributes**. This window appears:

![Attribute Process Menu](image)
To select an attribute, click the arrow next to *Amplitude Envelope* as shown above. This causes a list of attributes to appear. Notice that there are twenty-six attributes in all.

In this exercise, we will not use any additional attributes.

**Reading Data Slices into ISMap**

We now have seven data slices that have been created in the seismic view. The next step is to read these into our ISMap project and use them as secondary variables for the porosity estimation.

On the ISMap Main Window, go to **Select Data>New Seismic Data**: 

Then select **Project** on the **Read Seismic Data** window:
A list of 8 available slices appears. Use the Add >> (or Add all >> and << Delete) button to add all the slices, except for the *ch_top structure time*, from the Available to the Selected column, as shown below:

Click OK and the following window appears, allowing you to change the names if you want.
In our case, we will keep the same names. Click OK.

The slices will be added to the ISMap main window.

The updated ISMap Data List window appears, and it tells you that the averaged porosity values from the wells correlate with the inversion data slice with a correlation coefficient of -0.65496, which is very good. The other correlations are not as good. Select the first pair (Porosity and inversion ISMap) by clicking in any cell in that row. Then, click Show to see the main window.
Now, select **View>Display Options** on the main ISMap window and change it as follows (i.e. change the **Ranges** to **Scrolled** and the **Units / Inch** to **30**):

![Curve Display Menu](image)

The ISMap main window now looks like this:
If your color bar is not the same as above, you can either use the new color bar, if it seems appropriate, or select \textit{View>Change Color Amp} and change the window as shown below:

![Color Amplitude Range Menu]

Click \textbf{OK} and the map will be updated. Remember that if you want to change the color bar in more complicated ways, such as changing the colors or adding more intervals, you need to go to the \textit{View>Change Color Key} window.

Let us now perform a conventional geostatistical analysis. Recall that we have already computed the well-to-well variogram and the kriged map. Now, we need the seismic-to-seismic variogram. Click \textit{Variograms>Seismic to Seismic} and fill the window out in the following way:

![Calculate Variogram From Data]
Click **OK** and the following variogram appears:

We will not need a well-to-seismic variogram, since we will be using the **Markov-Bayes** approach, which uses a scaled version of the seismic-to-seismic variogram for the cokriged and KED (Kriging with External Drift) maps. To produce the cokriged map, click the **Kriging** button and fill out the window as shown below:
Click **OK** and the **Markov-Bayes** window appears:

![Markov-Bayes Parameters Window](image-url)

Click **OK** to get the cokriged result, shown next.

![Cokriging Result](image-url)

Notice that the channel is defined by this map.
To see the error associated with this map, select **Display>Latest Error>Co-kriging**. The following map will appear:

Now, click the **Kriging** button again and fill out the window as shown below to produce the KED result:
Click **OK** and the **Markov-Bayes** window appears again:

![Markov-Bayes Parameters](image)

Click **OK** to produce the next map shown.
To see the error associated with this map, select **Display>Latest Error>External Drift**. The following map will appear:

![External Drift Error Map](image)

Next, we will use the **EMERGE** option to produce a better starting map for geostatistical analysis. Before doing this, we will need to make sure that all the maps have the same grid. To do this, click **Define Grid** and fill out the window as shown below:

![Define Grid Window](image)

Next, click **Apply All** to apply to all of the maps.
**EMERGE Analysis**

So far, we have been using a single secondary data set to enhance the prediction of the primary data set. For example, in this recent exercise, we have used the Inversion data slice to aid in the prediction of porosity. We have also extracted quite a number of other attributes. Theoretically, we could now use each of those separately to make independent predictions of porosity. However, we can expect that using multiple attributes simultaneously should be better than using any of them individually. This is the process known as **EMERGE**, and we will apply this now.

To start that process, select **EMERGE>Start New Emerge Session** on the ISMap Main Window:

![EMERGE Analysis Window](image)

The **Emerge** Analysis window appears:

![Emerge Analysis Window](image)

At this point, the window is mostly empty, except for the list of data slices from our current project, which appear in the upper left corner.

The first step is to collect a set of data around each of the well locations for analysis. To do that click **Send To Analysis Table**:
The following window appears:

This window determines how many samples around each well location will be used in the analysis. The default **Search Radius** is 0, meaning that the nearest data slice sample is used with each well sample for the analysis. If you entered a different value, say 50, then all data slice samples within 50 (meters or feet) would be averaged to provide the data slice sample. This is a way of enhancing the signal to noise ratio, and avoiding spurious noisy samples just at the well location. For this analysis, we will accept the default and click **OK**.

Now we get a table which looks like this:
This table shows each of the well locations, the corresponding Porosity value from the well, and the corresponding seismic sample from each of the attributes. If you scroll the horizontal slider, you can see all the attributes in the analysis.

The first step in the analysis is to create the **Single Attribute List** by clicking the buttons as shown here:

![Image showing the Single Attribute List creation process]

We will accept the defaults on the analysis window, which means we will analysis all the attributes in the project:

![Image showing the Single Attribute Analysis window]

Click **OK** to run this process.
When the calculation has completed, the result window looks like this:

This shows each of the attributes correlated with the target, Porosity, ordered in decreasing correlation. This display shows that “inversion” correlates best with a correlation coefficient of (-0.65). We can also see a cross plot for this attribute as well as the predicted map which would come from using the regression curve to predict Porosity.

By clicking other rows on the Attribute list, we can see both the cross plot and the prediction map change.

However, this still does not show us how to use the attribute simultaneously to improve the prediction.
To do that select **Emerge>Create Multi Attribute List**:

Once, again we will accept all the defaults on the analysis window:

This is telling the program to analyze all the attributes. In this process it looks for combination of 2 attributes, 3 attributes, 4 attributes and 5 attributes. In each case it finds the best combination by **Exhaustive Search**. That means it examines all possible combinations of each type and stores the one with the lowest prediction error.

Start this process by clicking **OK**.
When the process has completed, the window looks like this:

This looks similar to the previous window, with two extra panels, which I will explain now.

This first panel shows a list of attribute names:

<table>
<thead>
<tr>
<th>Target</th>
<th>Final Attribute</th>
<th>Training Error</th>
<th>Validation Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>Porosity</td>
<td>inversion ismap</td>
<td>3.110006</td>
<td>3.486673</td>
</tr>
<tr>
<td>Porosity</td>
<td>seismic ismap phase rms average</td>
<td>2.626471</td>
<td>3.278960</td>
</tr>
<tr>
<td>Porosity</td>
<td>seismic ismap phase rms average</td>
<td>2.547127</td>
<td>3.825800</td>
</tr>
<tr>
<td>Porosity</td>
<td>seismic ismap phase rms average</td>
<td>2.534402</td>
<td>4.659856</td>
</tr>
<tr>
<td>Porosity</td>
<td>seismic ismap phase rms average</td>
<td>2.529246</td>
<td>6.741865</td>
</tr>
</tbody>
</table>
Actually, each line on this list is a combination of attributes. The number of attributes in each combination is the number on the left. To see exactly, which attributes correspond to each line, select Results>Attribute List:

This causes a pop-up window to appear, showing the exact combination for each line. For example, if you select line 2, the list looks like this:

```
<table>
<thead>
<tr>
<th>Target</th>
<th>Final Attribute</th>
<th>Training Error</th>
<th>Validation Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>Porosity</td>
<td>inversion ismap</td>
<td>3.11006</td>
<td>3.48663</td>
</tr>
<tr>
<td>Porosity</td>
<td>seismic ismap</td>
<td>2.02847</td>
<td>3.27586</td>
</tr>
<tr>
<td>Porosity</td>
<td>seismic ismap</td>
<td>2.54713</td>
<td>3.82580</td>
</tr>
<tr>
<td>Porosity</td>
<td>seismic ismap</td>
<td>2.53402</td>
<td>4.63856</td>
</tr>
<tr>
<td>Porosity</td>
<td>seismic ismap</td>
<td>2.52924</td>
<td>6.74185</td>
</tr>
</tbody>
</table>
```

This means that the best possible combination of 2 attributes are the ones shown on the list. If you use those exact weights as multipliers for the attributes, and add the constant shown, you will get the best possible prediction of porosity.

The Training Error, printed on the first list is the RMS average error between the actual Porosity and that predicted by this combination. Note that the result is 2.62%.
The second panel shows the cross plot between the actual porosity and that predicted by this combination. For example, if the second row is selected, the cross plot looks like this:

Note that any of these windows can be dragged out of the main window and enlarged to see them better. Note also that some more cross plot details can be seen by selecting View>Show Plot Title:

The enhanced Cross Plot description shows that this combination of two attributes predicts the Porosity with a Correlation value of 0.77:
The third panel shows a plot of prediction errors for each attribute combination:

![Error Plot](image)

The black curve shows the prediction error when all the wells are used in the analysis. The red curve shows the Validation Error. This is the average error when each well is left out systematically from the analysis and predicted using only the other wells. For most cases, this red curve goes through a minimum and then rises up, as shown above. We would conclude from this analysis that precisely two attributes are optimum for predicting Porosity. This is because the red curve goes through its minimum at two attributes. If we use three attributes, the average prediction error on a hidden well is actually larger than for two attributes, indicating that these three attributes are not helpful. In summary, we use this plot to determine exactly which combination of attributes is ideal. We do this by observing at which number of attributes the red curve goes through a minimum.

The plot at the bottom of the window show the Application of each attribute.

The Application plot shows the result of applying any particular derived attribute combination. For example, if you select the second line, the plot looks like this:

![Application Plot](image)

Note that, as shown, the window can be pulled out of its docking location for easier viewing.
A second useful plot is the Prediction Interval plot. To see that plot, click on Results / Prediction Interval:

![Prediction Interval plot](image)

This shows the range of porosity values for which we are 95% confident. The current plot looks like this:

![Current Prediction Interval plot](image)

Most of this plot is blue and purple, indicating a Prediction Interval of 15% (from the upper color scale bound). This means that in these regions, the porosity estimate is:

\[(\text{Application Plot value}) \pm 7.5\%\]

A lower number on the Prediction Interval plot means a higher confidence in the result and vice versa.

Note that if we wished to see the Prediction Interval corresponding to a different confidence level, we would select Results > Prediction Interval Parameters:
The **EMERGE** analysis has told us that using two attribute slices simultaneously is the best predictor of the Porosity values.

The final step in this process is to pass back the predicted Porosity map from **EMERGE** and use it as a secondary data set for cokriging in ISMap.

To do this, make sure the second row of the Multi Attributes list is highlighted and select **File>Save Transform Map**:

![Image]

On the resulting window, we will use the default name for the new map, which is “Porosity_using_2_attributes”:

![Image]

Click **OK** on this window.

Finally, close down the **Emerge Analysis Window**, by selecting **File>Exit**.

You will be prompted to save the current **EMERGE** session:

![Image]

Click **OK** to save this session. This will allow us to modify the **EMERGE** analysis later.
Reading EMERGE Slices

Now that we have saved the slice, we need to read it back into the project.

Go back to the ISMap main window and select Select Data>New Seismic Data, as shown below:

As before, select the Project option on the next window and click OK:

Then, select Porosity_using_2_attributes from the list of available data slices and click Add >>:
The next window confirms the name of the slice:

Click **OK**, and the updated **Data List** window comes up. Change the options to **Sort By:** **Correlation** in **Descending Order**. Notice the improvement of the correlation coefficient with the new map.

Finally, click the top row of this window and then click the **Show** button at the bottom of the window. A new window will appear, which contains the new **EMERGE** map, as well as the well log values.

If the color scale is not correct in this window, which can happen from time to time, select **View>Change Color Amp** and change the resulting window as shown below, by typing in 5 and 15 as the **Minimum** and **Maximum** amplitudes:
Click **OK** and the **ISMap** window will look like this:

![ISMap Window](image)

Now click the **Variogram** button, select **Seismic to Seismic** and fill out the window as follows:

![Variogram Window](image)
Click **OK** to get the following variogram:

![Variogram Plot](image.png)

Next, click the **Kriging** button and fill out the window as follows:
Note that we will perform collocated cokriging with the \textbf{Markov-Bayes} assumption (since the \textbf{Assume Linear Relationship} button is selected). Click \textbf{OK} to get the following window:

Click \textbf{OK} to get the final cokriged result:

This represents our best Porosity prediction, using the well data as well as 2 seismic attributes. This also completes the \textbf{ISMap} tutorial. Close the program by selecting \textbf{File} > \textbf{Exit Project}. 