GUIDE TO AVO

Introduction

AVO is a program used to analyze pre-stack seismic data for the purpose of evaluating and modeling Amplitude Versus Offset anomalies. The input data for this process consists of the following elements:

- One or more well logs.
- A pre-stack seismic volume, either 2D or 3D. This volume has usually been processed to the final CDP gather stage.

This tutorial takes you through the entire process of modeling and analyzing AVO anomalies on several seismic volumes.
1.0 Using GEOVIEW

GEOVIEW is a program provided to you along with AVO. GEOVIEW serves two purposes. The first is to read in and manage all well logs which are used by any Hampson-Russell program, including AVO. The second purpose is to launch other programs, such as AVO.

To start this tutorial, first start the GEOVIEW program. On a Unix workstation, do this by going to a command window and typing:

```
GEOVIEW <RETURN>
```

On a PC, GEOVIEW is initialized by clicking on the Start button and selecting the GEOVIEW option on the Programs / HRS applications menu.

When you first launch GEOVIEW, the first window that you see is the Opened Database List, which displays your recently used databases. For this tutorial, we are going to create a new database. To do this, click New:

On the Well Log New Database window, browse to the location you wish to store your new database information and then assign a new name for the database.
Call the new database *avo_guide*, as shown below. Note that this will create a directory called *avo_guide.wdb* on your computer, which will be used to store all the well logs used in the AVO analysis.

Click **OK** to complete creating the database.

**Reading Well Logs into GEOVIEW**

Once you have created a new database, the **GEOVIEW Well Explorer** window will appear, as shown below:
To load the AVO well, select **Import Data>Logs, Tops, Deviated Geometry from Files:**

We chose this option because we wish to load an LAS format file with all the curves for a particular well. This window appears:

![Image of the window](image)

We must select the file(s) containing the log curves that we want to add to our database. Select `avo_well.las`, as shown, and confirm that the **Log File Format** is set to **LAS**, as shown above.

Next, we need to specify the name of the well(s) into which we will load the logs.

Click **Next >>** to show the second page of this window. Change the default name for the **Destination Well Name** to `Colony_well`, as shown below:

![Destination Well Settings](image)
Click Next >> to see the next page as follows:

If values for the X & Y coordinates of the surface location of the well or the KB and surface elevations had been found in the header of the LAS file, they would have been entered on this window automatically. You can also specify them yourself by modifying the contents of the corresponding cell. For this well, we need to change only the Type to GAS WELL, as shown:

Click Next >> to proceed. After reading the file, the program creates this window showing you which curves have been detected in the LAS file. Click OK to accept all these curves:

You will see the following dialog asking you to confirm the measurement system. Click OK:
The **GEOVIEW Well Explorer** window now shows the well that has been added to the database.

If you would like to see a plot of the logs, select the well by clicking on its name in the **View** panel, and then click **Display Well**. The display looks like this. Note that the target gas zone has been identified with a set of tops called **TOP_GAS** and **BASE_GAS**:
Now let’s zoom in on the zone of interest. To do that, select **View>Vertical Zoom In**: 

![Zoom In Options](image)

This can also be done more easily using the middle icon shown below (i.e. the magnifying glass with a plus sign.) To undo this operation use the magnifying glass with a minus sign. To perform a more general rubber band zoom (and unzoom), use the magnifying glass icons shown below.

![Magnifying Glass Icons](image)

You will notice that the entire window zoomed in and that you have the ability to scroll up and down the entire log:
2.0 AVO Modeling

Now start the AVO program by clicking on AVO>AVO on the GEOVIEW main window:

A window appears, asking you if you wish to start a new project. Select that option and click OK:

On the File Selection window, browse to the location you wish to store your new project information and then assign the project a new name. We will call this project colony. This will create a directory named colony.prj, which will contain all the results of the AVO modeling which we are about to do. Click OK on the following window:
The **AVO** window appears. Initially, this window is blank, since we have not loaded any data:

![AVO window](image)

To start modeling, click **Modeling>Single Well**:
This following window appears, allowing you to select which well will be used to create the AVO synthetics. Since there is only one well, click **Open** to select the *Colony_well*.

The **AVO Model Definition** window appears:
The **AVO Model Definition** window specifies which logs will be used to define the model. In our case, we have only one P-wave and one density log available. Click **OK**.

The following information dialog appears:

This window appears because an offset dependent synthetic can only be created using a P-wave, a density, and an S-wave log. In our case, there is no S-wave log. We will create the S-wave log using Castagna’s mudrock equation, which relates S-wave and P-wave velocity by a linear equation. Click **OK** on this window and the **Transforms** page now appears. This will lead you through the creation of the S-wave log. We will accept the defaults on each page. The first page specifies that Castagna’s equation will be used.

Click **Next >>** to accept the default. The second page specifies that the *P-wave* log from the *Colony_well* will be used to generate the S-wave log, which we will call *S-wave_trans*:
Click Next >> to accept those choices. The third page specifies the coefficients of the assumed linear relationship between P-wave and S-wave logs. These are the published defaults from Castagna’s paper.

Click OK to use the defaults and the log display appears. We will change the appearance of the display by clicking on the Eyeball item as shown on the left of the icon bar below, to bring up the parameter display menu.

Change the window as shown below to display the P-wave log, density log, S-wave log and Poisson’s ratio log from left to right on the display. When you have set the logs as shown, click the button in the lower left corner of the window called Save settings as project template.
You will then be prompted with the message:

Click Yes and this display will become the default display, or template, for this project. You will not need to change the log display in this project unless you want to see a different ordering of the logs.

Finally, click OK on the main Parameter Window, and the AVO Modeling window shown below now contains all the logs required to create the offset synthetic.
Note that the S-wave log has been created from the P-wave log, and the resulting Poisson’s ratio log has been displayed. We do not expect this to be the final Poisson’s ratio log, since Castagna’s equation is valid only for the wet background shale. Within the target zone, we will have to use a different calculation to model the gas sand.

**Performing Fluid Replacement Modeling**

When we calculated the S-wave log using Castagna’s equation, we effectively modeled the entire log as a wet (brine-filled) log. To calculate the correct S-wave behavior for the gas sand, we need to use Fluid Replacement Modeling (FRM). To do that, click **FRM**:
When the FRM window appears, there are a series of pages. Fill in the first page as shown below. On this page, we are telling the program what the state of the target zone is before fluid replacement, i.e. this is the in-situ case:

![FRM Window](image)

Note that we have set the **Fluid Composition** as **2 phases: brine + gas** and have specified that the **Water Saturation** within the target layer is **50%**, which effectively means 50% gas. Some of the other important parameters have been defaulted. Under the field **S-wave option**, we have specified that Castagna’s equation is assumed to be correct for the wet sand case. Within the FRM module, the Biot-Gassmann equations will be used to convert the actual P-wave log within the target layer from the 50% water saturation to 100% water saturation. Then, Castagna’s equation will be used to calculate the correct shear-wave velocity for the layer at this water saturation. Finally, the Biot-Gassmann equations will be used again to correct from the 100% saturation case back to 50%, which is what we desire. Also, we do not specify the porosity within the zone, but allow the program to calculate it from the other parameters, assuming the measured density in the log **Density** is the true bulk density for the gas layer. When you have completed the changes as shown, click **Next >>**.

The second page specifies the window over which we will perform the FRM calculations. This defaults to the range between the first and second lithologic tops found in the well. We will use the defaults so that all depth samples within the range 633 m (the first top) and 640 m will be modified. Click **Next >>**.
The third page contains the Petrophysical parameters describing and the matrix and fluids. Note that the default is to assume that the matrix is sandstone and the hydrocarbon is gas. We will accept these defaults. Click **Next >>**.

The final page of the **FRM** window contains the output parameters after fluid replacement. All the defaults are correct. By keeping the **Porosity** and **Water Saturation** the same as the input, we are effectively modifying only the S-wave velocity within the target zone. We will create 3 new logs by this process, which will be used to calculate the new synthetic.
To check the results before applying them to the logs, click **QC Display**. Scroll over to see the Poisson’s ratio, as shown below:
Click **OK** on this window to perform the **FRM** calculation. You will see a series of warning messages. The first confirms that you want to create the new logs. Click **Yes**:

The second message asks if you wish to copy the depth-time curve associated with the input P-wave log. This question is asked because generally the P-wave log is modified and that could change the depth-time curve which correlates the synthetic with the real data. Since we have already correlated the two, we do not wish to modify the relationship. Therefore, click **Yes** on this window:

After the FRM calculation is completed, the **AVO Modeling** window is redrawn to show the new logs. Zoom up the display using the **Plus Sign** icon. Only the S-wave log and the resulting Poisson’s Ratio log are modified. Note that the effect of assuming the 50% gas saturation is to lower the Poisson’s Ratio within the target zone:
At this point in our AVO flow, we could create an offset-dependent synthetic seismogram using the P-wave sonic log, density log, and created S-wave log. The only problem with creating a synthetic seismogram at this point in the flow is that we lack three crucial bits of information necessary to make such a synthetic seismogram. These are:

1. The seismic wavelet
2. The seismic geometry (i.e. what are the correct near and far offsets)
3. The depth-to-time conversion information (this is because there generally is not enough information present in a sonic log to accurately tie observed seismic data).

If there is no available seismic data in the area, we can simply guess at the above three parameters. For example, we could use a Ricker wavelet with a dominant frequency equal to some average value for the wavelet, we could try various sets of geometry information, and we could use the uncorrected sonic log to perform the depth-to-time conversion. This is certainly the correct approach if we are using the AVO modeling method to predict suitable seismic parameters for an upcoming survey.

However, in this area we do have seismic data available in the form of a set of corrected CDP gathers that stack to create a 2D line. We will therefore read in this data and derive the needed information from the seismic data itself.

**Loading Seismic Data**

To read in the seismic data, select **Data Manager>Import Data>Open Seismic>From SEG-Y File**:

On the **File Selection** window, select the file *gathers.sgy* as the file to be read:

On the next series of pages, you supply information which is used to read the SEGY file and set up its geometry. These pages will be explained in more detail later in the tutorial when we read the 3D volume. Since we are reading a simple 2D line, we can default most of the parameters.
On the next page, specify that this is a **2D Line**:

![SEG-Y Seismic File Open](image1)

On the third page, you specify what information can be found in the trace headers. In our case, we do not have either Inline & Xline numbers or X & Y coordinates in the headers. Change the window as shown below:

![Trace Header Options](image2)

Click **Next >>**. The next page specifies details about where information is contained in the trace headers. The only important parameters for this line are the locations of the **CDP** numbers and **Offset** values:

![CDP and Offset Locations](image3)

Click **Next >>** to accept these defaults.

Now, the following warning message appears, indicating that the volume will be scanned. For a large file, this could take some time. Click **Yes** on this window.

![Scan Warning](image4)
The last page specifies the geometry for this data set. By default, the program assumes that this is a single inline with 131 cross lines. Click **OK** to accept this geometry.

Finally, the SEGY volume is plotted in the main **AVO** window:
At the same time, a window appears which allows you to specify where the wells are located with respect to the seismic volume. If we had been more careful to specify the correct location of the wells within the GEOVIEW database, the location would be correct in this window. We can modify this window to specify that the Colony_well is located at CDP 330. Type this number as shown below, click in one of the other fields and the other numbers will be updated automatically and the Plot toggle will be checked. This will mean that this well will be plotted at its correct location on the seismic volume. When you have modified the window as shown, click OK.

After moving the horizontal scroll bar so that CDP 330 is roughly centered you can see the P-wave log plotted at its correct location on the seismic line.
As well as seeing the seismic data in the main window you can see that a portion of the seismic data has also been displayed in the **AVO Modeling** window.

Note that the integrated sonic log does not appear to tie the seismic data very well on either plot. Let us see what it looks like on the CDP stack. To create the stack, select **Process>Stack > CDP Stack** … as shown below:

![CDP Stack Example](image1)

Use the window defaults to create the following plot:

![CDP Stack Plot](image2)
Now it is clear that the well does not tie. Note the “bright spot” at a time of 630 ms, centered on CDP 330, which obviously corresponds to the gas sand event on the log. To fix this, we need to correlate the well.

Before selecting the correlated option, we will extract a wavelet. There are two methods of wavelet extraction. One method compares the well log reflectivity with the seismic data, and calculates an operator, which shapes one into the other. We cannot use this method yet, since we have not correlated the two. The second method uses the seismic data alone to calculate a zero-phase wavelet whose amplitude spectrum matches that of the seismic. This is called Statistical Wavelet Extraction. To do this, select Wavelet>Extract Wavelet > Statistical on the sidebar menu, as shown here:

![Wavelet Extraction Menu](image)

Default the first window by clicking **Next >>**:  

![Volume Range Specification](image)
Note that this window simply defines the time and CDP window over which to perform the statistical wavelet extraction. We are using the complete dataset.

Fill in the next window using the parameters shown below. Note that we have changed the wavelet length to 100 ms:

![Wavelet Parameters](image)

Click **OK** and the wavelet appears, as shown below in time and spectrum formats:

![Wavelet Time and Spectrum](image)
Note that this wavelet is zero phase and has a dominant frequency of about 30 Hz, determined from the seismic data. That does not mean we know that the wavelet in the seismic data is zero phase. The statistical wavelet extraction procedure has assumed that. In order to determine the correct wavelet phase, we will have to use the Well Log wavelet extraction later. This wavelet will be used as the default wavelet in our modeling options until a new wavelet is chosen. Now that we have extracted a reasonable wavelet, we need to correct for the shifted log. Go back to the Modeling window and select Logs>Correlate:

We can perform the correlation on any of the seismic datasets but it is probably simplest to use the stack, as indicated below:

Click OK and the following window appears:
On this plot, we see the zero-offset synthetic in blue and the stacked trace (repeated 5 times), taken from the tie point at CDP 330, in red. Using the default options in the window below the display, click successively on the two main events that tie between the synthetic and seismic, as shown below (click the corresponding events on the synthetic first and then the seismic):
Note that orange lines are drawn between the events. Next, click the **Stretch** button to get the following two plots:

These plots show the pseudo-check-shot corrections which will be applied to the sonic log using these correlations. Click **OK** to accept the defaults.

The completed window now looks like this, with the well log properly positioned on the CDP stack:
Next, go back to the **Main Seismic** window. We now want to improve the signal-to-noise ratio of the data by creating a rolling super gather (often called a common offset stack). Choose **Process>Super Gather** as shown below:
A Super Gather is the process of forming average CDPs to enhance the signal-to-noise ratio. The averaging is done by collecting adjacent CDPs and adding them together. Use the defaults on the first window and click **Next >>**. Change the **Size of Rolling Window** to 5, as shown below:

Click **Next >>** and **OK** to produce the following plot of the super gathers:
Click the **Zoom** icon twice to produce the following plot:

Note from this zoomed plot that the range of offsets at CDP 330, which ties the well, is from 53 to 647 m. These values will be used in our synthetic calculation.

Click the **Unzoom** icon now to reduce the plot back to a smaller size.
Creating a Synthetic Seismic Display

Now, create a synthetic using these logs by selecting *Synthetic>Zoeppritz*:

Fill in the window as shown below:

This operation will create an offset-dependent synthetic using ray-tracing to calculate the incidence angles and the Zoeppritz equations to calculate the amplitudes. Only the primary reflection events will be modeled. We will create a synthetic seismogram with 10 offsets ranging from 53 to 647 meters, based on our super gather results. We are setting a **Target zone**
from 600 to 700 meters. This means that the Zoeppritz equations will be used to calculate reflection coefficients for any interface within this depth range (600-700m), but for all interfaces outside this depth range, the zero-offset reflection coefficient will be used to save computation time. When the window is filled in, click **Next >>** and then **OK**. When the synthetic calculation finishes, you will be prompted with the following message:

This will allow you to plot the synthetic in a separate seismic window. Since we only want to see the display on the modeling window, click **Close** to close this window. The calculated seismogram appears in the **AVO Modeling** window. Click the **Eyeball** icon, go to the **Seismic Views** tab and change the window as shown (remove the CDP gathers from the display, add the super_gather, and change the **Excursion** for the synthetic to 0.5):
Click **OK** on the **View Parameters Window** and the **AVO Modeling Window** will appear as below. Note that the appearance of this window changes because the scale has now been changed from a uniform depth scale to a time scale as shown at the left of the display. Also note the excellent match between the synthetic and the super gather at CDP 330.

Now we will compare the synthetic and real data more quantitatively by picking the events. Select the **Pick Horizon** option and change the **Horizon name** to **Horizon 1 Syn**, as shown below (also make sure the **Volume to pick**: is **colony_well_syn**):
Click OK to bring up the picking section under the display. Change the Snap option to Trough and use the Rubber Band mode to pick the trough above the gas sand, as shown below:

![Image of the AVO Modeling Window with Trough picking](image1.png)

Next, click the Horizon pull-down option and select <New Horizon>. Call this horizon Horizon_2_Syn, change the Snap option to Peak and use the Rubber Band mode to pick the peak below the gas sand, as shown below:

![Image of the AVO Modeling Window with Peak picking](image2.png)
Save the synthetic picks by clicking **OK**. Then, select the **Pick Horizon** option again, change the **Horizon name** to *Horizon 1 Seis*, and change the **Volume to pick**: is *super_gather*, as shown below:

![Horizon Selection Menu](image1)

Click **OK** and pick the top and base of the gas sand on the super gather in the same way we picked the synthetic. After exiting the picking option, the display will look as below:

![Display](image2)
Now we will display the picks. Select **Display>AVO Picks** to get the following window. Fill it in by selecting the four sets of picks.

![AVO Picks Menu](image)

Click **OK** to get the following display:

![Picks Display](image)

January 2007
Notice the excellent correlation between the synthetic picks and the real picks, although of course the real picks are much noisier.

We have now completed the first part of our AVO study. We have read in a set of well logs and a set of CDP gathers and used this data to produce an accurate AVO model. This involved the following steps:

1. Creating a wet pseudo-S-wave log using the mud rock relationship.
2. Using the FRM module to replace the wet zone with gas over the known gas zone interval.
3. Extracting a wavelet from the seismic data.
4. Correlating the logs with the stacked seismic data.
5. Creating a rolling super gather to increase the seismic signal-to-noise ratio.
6. Using the modeled logs, seismic wavelet and seismic geometry to create a synthetic seismic profile.
7. Picked the anomalous zones on the synthetic and real seismic profiles.
8. Displayed the picked events and got a good fit.

The comparison of the model and real super gather has given us a fair amount of confidence that we are dealing with a gas sand. A second quantitative analysis that we could have done is to compute and cross plot AVO attributes of the synthetic. Before doing this, we will turn our attention to the real dataset and show how to compute attributes over the whole line.
3.0 AVO Analysis on 2D Data

We have now completed the modeling phase of this project. In this section, we will perform AVO analysis on the real CDP gathers from the 2D data set which ties this well. Later in the guide, we will apply AVO analysis to a 3D data set.

To start, go to the window displaying the super_gather. If this window has been closed, simply select Seismic>Seismic Window Data Menu from either the processing or modeling window, as shown below:

Then, select super_gather on the window and click Show:
The picked horizon will also be displayed on your seismic data (and will look quite strange since we only picked one gather and the other values are being extrapolated). To remove the picks, click the Eyeball icon and select the Horizons tab, which should look like this:

![Seismic View Parameters Menu](image)

The default option is the show All Horizons in Project. Change this to User Defined, as shown below, and do not select any horizons. Click OK.

![Seismic View Parameters Menu](image)
The super gathers should then be displayed within an AVO window on your screen like this:

![AVO Window Screenshot]

Now, let’s produce AVO attribute volumes from the Super Gather. On that window, select AVO Attribute>AVO Attribute Volume:

![AVO Attribute Volume Selection]

Click Next >> to accept the defaults on the first page. The second page contains parameters particular to this process. The first thing we need to do is specify velocity information to be used in calculating the incidence angles:

![Velocity Information Table]

- **Time-Velocity Table**: (not specified)
- **P-wave Well Log**: (not specified)
- **SEGY file**: colony_well_syn_vp
- **Interval Velocity**: colony_well_syn_vp
- **ms smoothing on velocity**: 500

January 2007
There are three ways to do this: import a table of times and velocities from an ASCII file, use a sonic log from the database, or supply the velocities in the form of a SEGY file. We will use the second way. We still need to specify which log to use. Click the Open Well Log button. Select the name Colony_well. Note that we actually have 3 different P-wave logs in this well. Click P-wave_corr to select that one. The window now looks like this:

Now, click OK on this window to accept that sonic log as the velocity control for the AVO attribute calculation. The main window looks like this:
We will accept all the remaining default parameters for this calculation. Click Next >> and OK to start the process. The result automatically appears as a color plot:

The wiggle traces are the intercept traces. The color attribute is, by default, the product of intercept and gradient, A*B. This is most appropriate for a Class III AVO anomaly, and in this case, we can see the strong red (positive) response at the top and base of the gas sand at about 630 milliseconds.

To see other AVO attribute combinations, click the Eyeball icon to show the Seismic View Parameters window. On this window, the other combinations are listed under the Color Data Volume field:
Another very useful AVO attribute is *Scaled Poisson’s Ratio Change*. Select that item, as shown above, and click **OK** on the parameters window to redraw the window:

As you can see, this attribute also highlights the AVO anomaly on this data very well. The final process we will apply is to cross plot the calculated Intercept and Gradient. To do that, select **AVO Analysis>Cross Plot**:

The first page of the window is used to select the range of traces for the cross plot. In this case, we will select about 60 traces around the anomaly:

| CDP | From: 300 | To: 360 | By: 1 |
When you have changed the window as shown, click **Next >>** three times. The fourth page is primarily used to determine the time window over which the cross plot data will be collected. In our case, we will use a constant time window of 100 ms, centered at the time of 630 ms, which is close to the anomaly. In addition, we will plot only the *Peaks & troughs* of the data to reduce the volume:

![Seismic Event Specification](image)

When you have made these changes, click **Next >>** and **OK** to produce the cross plot:

![Crossplot Display](image)
The cross plot shows a large wet trend through the origin and the second and fourth quadrants, as well as anomalies in the first and third quadrants, as expected for a Class III anomaly. To highlight these regions, click **Zones>Add**. A new window appears which controls the zone description. The first zone often is the wet trend, so it is colored gray, by default. However, we will change the **Zone Mode** to **Ellipse** as shown below:

![Zone Mode Change](image)

After changing the window, use the mouse to highlight a region as shown below (click once, drag to define a line, click again, and then drag to open up the ellipse) and click **Apply**:

![Zone Highlight](image)
Note that if you are not satisfied with the area enclosed by this ellipse, you can click one of the points on the outside and drag this point to change the shape, or you can “click and hold” in the middle of the ellipse and move it around the cross plot. Once you are happy with the definition of the wet trend, go back to the Add/Edit Zone Filter and use Current Zone Selection to Add New Zone. The default color is yellow. Change the Drawing Mode to Rectangle:

We are going to pick the anomalous data in quadrant 3, which should be the top of the gas sand. When you have changed the window, outline the second region with a rectangle and click Apply:
Again, you can change the shape and position of this zone if you wish. Next, add Zone 3 and change the **Drawing Mode** to **Polygon**, as shown below. The default zone color is now blue.

Outline the third zone as shown and click **Apply**.
Finally, still using the polygonal option, define a fourth zone as shown below:

Now click **OK** on the **Add/Edit Zone Filter** window to save these zones.

Next, select the **Cross-Section** option on the left of the **Cross Plot** window. This produces a small display with the data used to create the cross plot. Note that the anomaly has been well defined by the zone selection:
We would also like to see the zone selection throughout the entire data set. To do this, go back to the window containing the AVO attributes and click the **Eyeball** icon. This causes the **Seismic View Parameters** window to appear:

Trace Data Volume: Intercept (A)  
Color Data Volume: Cross Plot  
Color Attribute: Seismic Amplitude

You will find the option *Cross Plot* under the **Color Data Volume** list. Select that item as shown above, and click **OK**. Now the cross plot zones are annotated throughout the 2D data volume:

Now, let’s produce several different AVO attribute volumes from the Super Gather. On that window, click again on **AVO Attribute>AVO Attribute Volume**:
Click **Next >>** to accept the defaults on the first page. The second page contains parameters particular to the **Attribute** extraction process. The first thing we need to do is specify velocity information to be used in calculating the incidence angles, but notice that this has been done already to compute the A and B attributes. In this part of the guide we will extract the Rp and Rs, or two term Fatti, attributes. The physical interpretation of Rp and Rs are that they represent the zero-offset P-wave and S-wave reflectivity, respectively. These attributes are computed using a least squares fit to the amplitudes as a function of angle, using the first two terms of the equation:

\[ R_{pp}(\theta) = c_1 R_p + c_2 R_s + c_3 R_D, \]

where \( c_1 = 1 + \tan^2 \theta, \quad c_2 = -8 \gamma^2 \sin^2 \theta, \quad c_3 = -\frac{1}{2} \tan^2 \theta + 2 \gamma^2 \sin^2 \theta, \quad \gamma = \frac{V_s}{V_p}, \)

\[ R_P = \frac{1}{2} \left[ \frac{\Delta V_P}{V_P} + \frac{\Delta \rho}{\rho} \right], \quad R_S = \frac{1}{2} \left[ \frac{\Delta V_S}{V_S} + \frac{\Delta \rho}{\rho} \right], \text{ and } R_D = \frac{\Delta \rho}{\rho}. \]

Change the **Type of Analysis** option as shown:

![AVO Attribute Process Menu](image)

Click **Next >>** and **OK** to create the result.
You will notice that the scaling is a little “hot” so used the **Eyeball** icon to bring up the **View Parameter** window and go to the **Color Key** tab, as shown here:

![View Parameter Window](image)

Click the check mark next to **Normalized Scale** to turn this feature off and select the **Data Range** button and change the numbers as shown next:

![Data Range Window](image)
Click **OK** on this window and the main window to get the following plot:

The wiggle display shows the P-wave intercept values. The color display is a combination of $R_p$ and $R_s$ called the fluid factor, $\Delta F$, in which we have assumed that $V_p/V_s = 2$, and given by the equation:

$$\Delta F = R_p - 0.58R_s .$$

Note the excellent definition of the gas anomaly. By clicking the **Eyeball** icon and the **Color Key** tab you can also display the individual $R_p$ and $R_s$ sections in color. The window looks like this:
Selecting the Rp option and changing the menu bar as shown (an amplitude range between + and – 20000) gives the following display:

![Display 1](image1.png)

Selecting the Rp option and changing the menu bar as shown (an amplitude range between + and – 100000) gives the following display:

![Display 2](image2.png)
These individual $R_p$ and $R_s$ sections can be opened in the STRATA program and independently inverted. The inverted $P$ and $S$ impedances can then be used for processes such as lambda-mu-rho, or LMR. Alternately, we can perform simultaneous inversion of a set of angle gathers in the STRATA program. (For more information on this, see the STRATA guide).

To produce the angle gathers, go to the window containing the super gathers and select **Process>Angle Gathers:**
Use the defaults on the first window to process the whole line, click **Next >>** and fill in the next window as shown:
Click **Next** >> and **OK** to produce the angle gather output.

These gathers can be used in STRATA for simultaneous inversion.

**Exiting the Project**

We have now completed this tutorial through the AVO program with the 2D data volume. To exit the project, select **File>Exit Project** on any of the AVO windows:

You will be prompted to save your project. Click **Yes** if you wish to return to this project at a later time.
4.0 AVO Analysis on 3D Data

In this section, we will perform AVO analysis on a 3D volume, which has been supplied. You have also been supplied with a well which ties this volume. This well has already been loaded into a GEOVIEW database. To open the GEOVIEW database, go to the GEOVIEW main window and choose Database>Open:

Select the database avo3d_database.wdb as shown below and then click OK:
The **GEOVIEW Well Explorer** shows a single well, called *avo3d_well* as shown below:

Select this well in the **View** panel and then click **Display Well**:

January 2007
We are now ready to start the analysis of the 3D volume. Select **AVO>AVO** on the **GEOVIEW** main window:

When the following window appears, click **OK** to **Start a New Project**:

Give this project the name **avo3d_project** and click **OK**:
An empty window now appears:

The first thing you need to do is read in a 3D seismic volume. To do this, select **Data Manager>Import Data>Open Seismic>From SEG-Y File:**

Another method of loading seismic data is to read from an existing Hampson-Russell project. You can use this option to open volumes which are contained within the current project or a different project.

The file selection window appears. Select the file `avo3d_seismic.sgy` and click **Next >>:**
On the second page of this window click **Next >>** to accept the default and load this as a 3D survey:

![Image of SEG-Y Seismic File Open window]

The third page of the SEGY file loading window contains general questions about how we wish to read the file. In this case, we want to read both the Inline & Xline numbers and the X & Y coordinates from the trace headers.

Click **Next >>** to show the fourth page:

![Image of SEGY file loading window with data]

January 2007
This page contains very detailed information about which byte locations within the trace headers contain various pieces of information. In this case, the header locations are correct, so click **Next >>**. Now we see the following warning message, indicating that the program will read through the SEGY volume to extract information:

![Warning Message]

Click **Yes** to continue.

The final window which appears is the geometry window. In this case, the parameters have been determined correctly from the contents of the trace headers:

![Geometry Window]

Click **OK** to complete the data loading process.
After the data has been read, three new windows appear. The first is the seismic window with the data displayed:

The second is a small window showing the list of volumes currently in this project:

Of course, there is only one volume right now. Click Close to remove this window.
The third window is the **Well to Seismic Map** window:

![Well to Seismic Map Window](image)

This window shows each of the wells in the database (there is only one) and its corresponding position within the 3D seismic volume. Because we have entered the X & Y coordinates of both the well and the seismic correctly, the mapping is correct. If we had not done so, we could edit this table, by typing in new values of the Inline and Xline at which the well is placed. Since the mapping is correct, click **OK** on this window.

Let us now change some of the display parameters for this data set. To do that, click the **Eyeball** icon to bring up the **View Parameters** window. As you have seen, the **Seismic View Parameters** window has a series of pages which control the display. On the **General** page, change the **Trace Excursion** to reduce the amplitude gain:

![Seismic View Parameters Window](image)

Click the **Scale** tab at the top of the window:

On that page, change the trace plotting scales:

![Seismic View Parameters Window](image)
Then click **OK** on the **Seismic View Parameters** window. The window will now look like this:

![Seismic View Parameters Window](image)

We can navigate through the 3D volume by using some of the tools at the top of the window. For example, by clicking on the arrow, we can move to the next inline:

![Inline Navigation](image)

Or, by typing a new number in the Inline number field, we can jump to a different line. Enter 31 as shown below:

![Inline Number Entry](image)

We can also see data in the **Xline** direction by changing this toggle:

![Xline Toggle](image)
Leave the display in **Inline** mode, and move the horizontal scroll bar to display the gathers around **Xline** 100. Notice that we now see the inserted P-wave sonic log from the well:

### Importing a Picked Horizon

Now we will read in a previously picked horizon. To do that, select **Horizon>Import Horizons>From File:**

---

January 2007
Select the horizon *avo3d_horizon.txt* and click **OK**:

On the first page of the **Specify Pick File Format** window, the defaults are correct:

Click **Next >>** to get the second page. In order to fill in this page, we need to look at the file. Select the file as shown below and click **Display selected file**:

The first few lines of the file look like this:

```
D:\Data\avo_data\avo3d_horizon
956.9  1   1
958.7  1   2
959.1  1   3
958.3  1   4
958.5  1   5
959.3  1   6
959.3  1   7
960.3  1   8
```
We see that the second page should be completed as shown:

```
Column Number

Inline Column:    2
Xline Column:     3
Pick Column:      1

Number of lines to skip before actually reading data: 0
```

When you have filled in the window as shown above, click **OK** to read in the horizon. This dialog indicates that all of the picks were loaded successfully:

```
== Pick Read Summary ==
D:\Data\avo_data\avo3d_horizon.txt:
Picks in file: 6241
Picks inserted: 6241
```

![Seismic data: avo3d_reimic](image)

January 2007
Because this horizon was a post-stack horizon, the picked event appears at a constant time across all traces of each CDP. We will use this horizon as a guide for extracting data slices from the volume. To see a map of the horizon times, select **Horizon>Display Horizons**:  

On the subsequent window, click **OK** to accept the defaults:

The resulting map shows that the horizon has not been picked across a faulted region:
Applying AVO Processing

Now, we will apply a series of AVO processing steps. The first procedure we will apply is the Super Gather. As discussed previously, the Super Gather is used mainly to increase the effective signal to noise ratio, while maintaining the AVO amplitude information. A second feature, which can be very important for large data sets, is to reduce the data volume. We will achieve both these results in this step.

On left side of the AVO window, select Process>Super Gather:

Default the parameters on the first page of the window and click Next >> to get the next page. Change the parameters as shown:

- Number of offsets: 20
- Single bin output: unchecked
- Size of Rolling Window: Xline 3, Inline 3
- Type of Calculation: Mean
On this page, we are specifying a rolling window which is 3 Inlines by 3 Xlines. This means that for each output CDP, 9 adjacent input CDPs will be averaged. Also, we are specifying that each output CDP will contain 20 traces. When you have modified the window as shown above, click **Next >>** and **OK** to start the process. When the Super Gather process has completed, display the gathers around Inline 31 and Xline 100. The window will look like this:

![Image of Super Gather window](image)

Note that the data is now cleaner than the input volume. However, one of the problems with this data set is that there is significant residual moveout. To correct this we will apply **Trim Statics**. **From the Super Gather window**, choose this option as shown:
On the first page, select all the defaults and click **Next**. On the next page, modify the **Window Length** and **Maximum Time shift** as shown below. We will be analyzing a single window of length 600 ms, starting at time 802 ms.

Click **Next** >> and **OK** to create the shifted volume shown below:

Note that the key event is now flat.
The next process we will apply is the Angle Gather. In this process, each input sample is mapped to its corresponding incidence angle. This allows us to look at the distribution of incidence angles at the zone of interest to make parameter decisions. For this process, we will use the Super Gather volume as the input. Start this process from the window containing the Super Gather by selecting **Process>Angle Gather**:

![Angle Gather window](image)

On the first page, we will accept the defaults, which will process all the input data and create an output volume called `angle_gather`. Click **Next >>** to get the next page, and change the number of angles to 30 and the far angle to 90 degrees as shown:

Number of angles: 30

Angles: From 0 To 90

Then click the **Open Well Log** button to select the log from the **GEOVIEW** database. Select the well `avo3d_well`. Finally, select the P-wave log. The window will look like this:

![Well log selection](image)
Now click OK on the Log Chooser window and Next >> and OK on the main window to start the Angle Gather process. When the process has completed, the result appears in a new window. Display Inline 31 and Xline 100 to see the zone of interest:

We can see that there is a strong AVO anomaly at around 1200ms. We can also see that the maximum reliable angle range is about 60 degrees. We will use this information in the subsequent calculations. Now we will produce Range Limited Stacks. These are CDP stacks averaged over specified offset or angle ranges. The input for this process is the Super Gather. Go to the window containing the Super Gather Shifted and select Process>Stack>Range Limited Stack:
Once again, we will accept the defaults on the first page, processing the entire input volume and creating an output volume named `range_limit_stack`. Click **Next >>** to get the next page. To fill in the window as shown, first select **Angle** as the **Type of ranges**. Then, fill in the rest of the parameters as shown:

![Range Limited Stack Menu](image)

When the window has been filled in as shown above, click **Next >>** and **OK** to start the process. When the calculation has been completed, you will see two windows appear: one window contains the near angle stack (0-30 degrees) and the other window contains the far angles (30-60 degrees). Go to Inline 31 on both windows. You will note that the anomalous zone at the center is much stronger on the far angle volume:

![Waveforms](image)
The final AVO process we will apply is the calculation of the intercept and gradient attributes. Once again, we will use the Super Gather as the input to this process. To start that, go to the window containing the Super Gather and select **AVO Attribute>AVO Attribute Volume**:

Accept the defaults on the first page and click **Next >>** to view the second page. The main change to make on this page is to set the Angle range from 0 to 60 degrees. Also we have set the **Minimum Acceptable Correlation** to 0.7, which means that any samples for which the regression fit is less than 0.7 will be flagged as an invalid sample in the output file.

When you have filled in the window as shown above, click **Next >>** and **OK** to start the process.
The result will look like this:

![Graph showing AVO anomaly](image)

By default, the color display shows the product of intercept and gradient (A*B).

This is not the best option for this Class II AVO anomaly. To change that, click the Eyeball icon. Then change the **Color Data Volume** to **Scaled Poisson’s Ratio Change**:
The new display shows a strong AVO anomaly at around 1200 ms:

![Graph showing AVO anomaly](image)

**Creating Data Slices**

We can also create a data slice through the AVO Attribute volume. To do that, go to the window containing the intercept and gradient and select **Data Slice>Create Data Slice**:

![Data Slice dialog box](image)

On the first page, we choose to plot the *Scaled Poisson’s Ratio Change* attribute, which is the same as that plotted on the AVO window. Also, we choose to calculate the *Amplitude Envelope* of this attribute. Effectively, this will apply a low-frequency smoother to the attribute and return us the energy, independent of the phase of the data.
On this page, we specify how the data slice will be extracted from the data volume. The parameters shown above specify that we will average over a 30 ms window (Window Size) below (Average Window Below) the picked event avo3d_horizon.
Click **Next >>** and **OK** to create the data slice:

The data slice shows a strong amplitude trend through the well location. This is the area where the change in Poisson’s Ratio is greatest, which could be indicative of a gas sand.

One important use of the data slice is to extract an arbitrary line through the anomalous region. To do that, go to the data slice and select **Arbitrary Line>Start Drawing**: 

On the **Arbitrary Line** window, select **super_gathe_shifted** as the input volume:
This means that even though we are drawing the arbitrary line on the Scaled Poisson’s Ratio Change slice, the data will be extracted from the super_gather_shifted volume. Also, note that we are creating a file called *arbitrary_line*. When you have modified the window as shown above, go back to the data slice display and use your mouse to draw an arbitrary line through the anomalous region:

As you move the mouse around, note that the line segment tracks the mouse like a rubber band. Clicking the left mouse button fixes a turning point on the arbitrary line. Clicking the right mouse button completes the drawing. If you need to start the drawing over, click **Reset** on the **Arbitrary Line** window.

When you have drawn an arbitrary line similar to the one shown above, click **Next >>** to see the node points that have been selected. We have not shown this window here because your nodes will undoubtedly be different than any other set of values.

Click **Next >>** and **OK** on the **Arbitrary Line** window. When the calculation has completed, a new window appears, containing those CDPs within the arbitrary line region.
The extracted arbitrary line will look something like this:

![AVO Program Interface](image)

**Saving the Project and Exiting**

We have now completed this tutorial of the AVO program. You will note that quite a few files have been created. To see a list of all these files, go to any of the AVO windows and select **Project>Seismic Window Data Menu**:
This causes the **Data List** to appear:

By clicking on any of these names, and pressing the **Show** button, an **AVO** window containing that data will appear.

Now, we will close down the **AVO** program. To do that, go to any window and select **File>Exit Project**:

Two last prompts will appear, asking you if you really want to exit the program and whether you want to save the project.

Click **Yes** on the first prompt and **Yes or No** on the second, depending on whether you want to save your results.